Garey's Blog–FreeBSD/PHP/GoLang

一月 12th, 2010

FreeBSD 8.0从USB移动硬盘启动的Bug?

8,617 views, FreeBSD, by garey.

我先将硬盘接到电脑的IDE接口装好系统,并设置好磁盘分区标签:

代码:

root@test:~# mount
/dev/label/rootfs on / (ufs, local)
devfs on /dev (devfs, local, multilabel)
/dev/label/data on /data (ufs, local, soft-updates)
/dev/label/home on /home (ufs, local, soft-updates)
/dev/label/tmp on /tmp (ufs, local, soft-updates)
/dev/label/usr on /usr (ufs, local, soft-updates)
/dev/label/var on /var (ufs, local, soft-updates)

然后将硬盘接到USB硬盘盒内,让机器从USB硬盘启动,在启动过程中报错:

代码:

Root mount waiting for: usbus4
umass0:0:0:-1: Attached to scbus0
Trying to mount root from usf:/dev/label/rootfs
ROOT MOUNT ERROR:
If you have invalid mount options, reboot, and first try the following from the loader prompt:
set vfs.root.mountfrom.options=rw
and then remove invalid mount options from /etc/fstab.
Loader variables:
vfs.root.mountfrom=ufs:/dev/label/rootfs
vfs.root.mountfrom.options=rw
Manual root filesystem specification:
<fstype>:<device> Mount <device> using filesystem <fstype>
eg. ufs:/dev/da0s1a
eg. cd9660:/dev/acd0
This is equivalent to: da0 at umass-sim0 bus 0 target 0 lun 0
da0: <WDC> Fixed Direct Access SCSI-0 device
da0: 40.000MB/s transfers
da0: 114473MB (234441648 512 byte sectors: 255H 63S/T 14593C)
mount -t cd9660 /dev/acd0 /
? List valid disk boot devices
<empty> Abort manual input
mountroot>

当时按? List显示:

代码:

mountroot> ?
List of GEOM managed disk devices:
acd0
Loader variables:
vfs.root.mountfrom=ufs:/dev/label/rootfs
vfs.root.mountfrom.options=rw
Manual root filesystem specification:
<fstype>:<device> Mount <device> using filesystem <fstype>
eg. ufs:/dev/da0s1a
eg. cd9660:/dev/acd0
This is equivalent to: mount -t cd9660 /dev/acd0 /
? List valid disk boot devices
<empty> Abort manual input
mountroot>

只看到acd0,没有da0
当我在另一个USB接口接了一块U盘时,却顺利进系统了。
这个时候我发现移动硬盘是da0,U盘是da1。
当我把两个USB接口互换时,又出现上面那个问题,? list时看到acd0,da0,da0s1,这个da0明显是U盘。
最后总结出来,只有将移动硬盘接在那个固定的USB接口,另一个USB接口随便接个U盘就可以启动移动硬盘上的系统。
虽然系统可以用了,但这个结果让人很困惑,不知道这是不是FreeBSD 8.0的一个Bug?

Back Top

回复自“FreeBSD 8.0从USB移动硬盘启动的Bug?”

  1. 我也碰到这个问题。(u盘只读文件系统)系统配置都是正确的,就是挂载失败,用笔记本稍等几秒,重新:ufs:/dev/da0s1a 又能挂载。用台式机就挂载不了。先前用7.2-RELEASE启动都没有问题,我想可能是8.0-RELEASE有问题,不知问题在哪?

    fullxml

发表评论

电子邮件地址不会被公开。 必填项已用 * 标注

*